No input file specified - RESOLVED (hopefully)

User avatar
Mort
Alpha-Forum Whore
Alpha-Forum Whore
Posts: 4231
Joined: Thu Dec 01, 2005 10:40 pm

No input file specified - RESOLVED (hopefully)

Postby Mort » Sat Dec 07, 2013 12:59 pm

Is anyone else getting a error when using the forums sometimes? "No input file specified." Refreshing the page then seems to load it.

It seems like something has changed recently to cause it, but I have no idea what. I've just started noticing it today.

User avatar
DJDrDamage
Clan Pincushion
Posts: 797
Joined: Fri Dec 02, 2005 9:45 am
Location: melbourne

Re: No input file specified.

Postby DJDrDamage » Sat Dec 07, 2013 10:12 pm

yah, for a couple of days now.
Image

User avatar
Mort
Alpha-Forum Whore
Alpha-Forum Whore
Posts: 4231
Joined: Thu Dec 01, 2005 10:40 pm

Re: No input file specified.

Postby Mort » Sat Dec 21, 2013 1:11 pm

This is getting quite annoying now. I've made a duplicate copy of the database and the website and all the settings and permissions and I can't get the copied site to throw the same error. This is running on the same server with the same IIS and php install.

*Obviously* there is something different between the two sites, but I have no idea what at this stage.

Investigations continue. (even posting this as a quick reply only throws the error on the original site!)
Image

User avatar
Mort
Alpha-Forum Whore
Alpha-Forum Whore
Posts: 4231
Joined: Thu Dec 01, 2005 10:40 pm

Re: No input file specified.

Postby Mort » Sat Dec 21, 2013 1:12 pm

It seems that using "Post Reply" rather than quick reply doesn't throw the error (as often?)
Image

User avatar
Mort
Alpha-Forum Whore
Alpha-Forum Whore
Posts: 4231
Joined: Thu Dec 01, 2005 10:40 pm

Re: No input file specified.

Postby Mort » Sat Dec 21, 2013 2:43 pm

Right, I think I may have a candidate for the cause of the problem. I can't get it to happen now, so please let me know if you are still getting the error, or if it re-appears sometime in say, the next 5 days.

If it does re-appear then I will definitely know the reason and can stop it happening again.
Image

User avatar
Mort
Alpha-Forum Whore
Alpha-Forum Whore
Posts: 4231
Joined: Thu Dec 01, 2005 10:40 pm

Re: No input file specified - RESOLVED (hopefully)

Postby Mort » Sun Dec 22, 2013 11:54 am

Good news, it happened again this morning so I'm fairly sure I know the cause now. It looks like an issue with IIS/php and the servers file deduplication process. I've now disabled de-dupe for that web site and will now watch to see if it happens again.
Image


Return to “Web site Issues/suggestions/stuff”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest